Новый ABX-компаратор (GStreamer/Linux/GNOME)

Список разделов Ogg Vorbis Потрепаться

Описание: Обсуждение всего, что не относится к тематике сайта

Сообщение #1 artfwo » 20.06.2006, 06:50

Привет всем!
Я регулярно читаю ваш форум, но пишу впервые, поэтому может и не в тему пишу... :)
Вот, обьявляю о выходе нового ABX-компаратора для Linux/GNOME:
http://abx-comparator.berlios.de

Если интересно кому, обсуждаем в этой теме :)
artfwo
Заинтересованый
Аватара
С нами: 11 лет 3 месяца

Сообщение #2 arcman » 20.06.2006, 10:43

А "requirements Python >= 2.4" никак не изменить?
Может можно проект подправить, что бы он распоследние питоны не требовал?
Лично у меня ASP Linux v10 - там 2.3.3 версия питона.
Не думаю что в других популярных дистрах сильно новее.
Качать почти 8 МБ, потом ставить питон - занятие не самое приятное ;)
Лично я бы на C делал изначально :)
arcman
Последователь
Откуда: Kazan
С нами: 11 лет 6 месяцев

Сообщение #3 arcman » 20.06.2006, 11:03

artfwo
Всё - забил на установку.

Сама прога при запуске пишет:
"Traceback (most recent call last):
File "./abx-comparator", line 26, in ?
import pygst
ImportError: No module named pygst
"

PyGTK 2.8.6 при установке пишет:
"checking for GLIB - version >= 2.8.0... no
*** Could not run GLIB test program, checking why...
*** The test program failed to compile or link. See the file config.log for the
*** exact error that occured. This usually means GLIB is incorrectly installed.
configure: error: gobject is required to build pygtk?
"
gst-python-0.10.4 пишет:
"checking for GST... Package gstreamer-0.10 was not found in the pkg-config search path.
Perhaps you should add the directory containing `gstreamer-0.10.pc'
to the PKG_CONFIG_PATH environment variable
No package 'gstreamer-0.10' found
configure: error: Package requirements (gstreamer-0.10 >= 0.10.2) were not met.
Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively you may set the GST_CFLAGS and GST_LIBS environment variables
to avoid the need to call pkg-config. See the pkg-config man page for
more details.
"

Мне пока хватило...
Вывод - или давать подробную инструкцию по установке всех компонентов, или переписать на C и использовать только станлартные возможности (можно вообще консольную версию для начала забахать)
arcman
Последователь
Откуда: Kazan
С нами: 11 лет 6 месяцев

Сообщение #4 artfwo » 20.06.2006, 11:33

1. Для начала поставь *-devel пакеты для соответствующих компонентов: glib, gtk, gstreamer-0.10 (если у тебя gstreamer-0.8, всё достаточно просто компилируется из исходников и ставится в домашний каталог (напр. /home/artfwo/opt/gstreamer))

2. Туда же поставь pygtk и gst-python

3. Пропиши подходящий PYTHONPATH если ставил в домашний каталог.

ВСЕ сегодняшние дистрибутивы включают нужные версии библиотек, Питону-2.4 уже полтора года (вроде бы)...

На C такие програмки писать неудобно, так как есть заморочки с памятью, если используешь GTK. На Питоне (Ruby, C#) получается лучше и быстрее (в смысле скорости написания кода) :) Консольные ABX-еры под Linux есть, а гномовский я написал, потому что люблю простые графические утилитки на GTK, которые хорошо делают свою работу :)

p. s. Я сам не люблю ASPLinux и другим не советую :) Возьми лучше Ubuntu, Slackware, Gentoo и в крайнем случае родную Федору (в порядке моего предпочтения).
artfwo
Заинтересованый
Аватара
С нами: 11 лет 3 месяца

Сообщение #5 arcman » 20.06.2006, 11:58

artfwo
За что ASP не любишь? Я за ним особых проблем не заметил.
Мне, по работе, подходят дистрибутивы только на основе RedHat.
arcman
Последователь
Откуда: Kazan
С нами: 11 лет 6 месяцев

Сообщение #6 artfwo » 20.06.2006, 12:56

arcman писал(а):artfwo
За что ASP не любишь? Я за ним особых проблем не заметил.
Мне, по работе, подходят дистрибутивы только на основе RedHat.

ASP не люблю за консерватизм и необходимость много чего настраивать через жопу после установки. Не знаю как текущие версии, но раньше было помню именно так :(

Если тебе надо RedHat, то лучший вариант (по-моему) - "родная" Федора (т. е. Fedora Core): никаких конфликтов и косяков в последней (пятой) версии вроде не было, но я сейчас редко с ней сталкиваюсь, у меня самого стоит Ubuntu Dapper...
artfwo
Заинтересованый
Аватара
С нами: 11 лет 3 месяца

Сообщение #7 v_2e » 16.07.2010, 23:54

artfwo писал(а):Вот, обьявляю о выходе нового ABX-компаратора для Linux/GNOME:
http://abx-comparator.berlios.de

Если интересно кому, обсуждаем в этой теме :)
Добрый день!
Вот мне интересно это обсудить. Дело в том, что эта программа у меня не работает. Она запускается, окно появляется, но когда я добавляю, скажем, MP3 -файл в первое поле, программа пишет в консоль вот это:
Код: Выделить всё
Traceback (most recent call last):
  File "./abx-comparator", line 124, in _on_a_chooser_selection_changed
    self.__load_a(uri)
  File "./abx-comparator", line 265, in __load_a
    message, secondary = value
ValueError: need more than 1 value to unpack

Затем я добавляю второй файл. В консоли появляется вот это:
Код: Выделить всё
Traceback (most recent call last):
  File "./abx-comparator", line 132, in _on_b_chooser_selection_changed
    self.__load_b(uri)
  File "./abx-comparator", line 282, in __load_b
    message, secondary = value
ValueError: need more than 1 value to unpack
И на этом конец. Кнопки остаются "серыми" (т.е. не активируются для нажатия). И делать в программе дальше нечего. :(
Вы не могли бы разобраться, в чём ошибка, ибо я сам в Python не понимаю ни капли. А я готов тестировать новые версии до полного искоренения ошибок. :)
v_2e
Заинтересованый
С нами: 7 лет 2 месяца


Вернуться в Потрепаться

Кто сейчас на форуме (по активности за 10 минут)

Сейчас этот раздел просматривают: 1 гость

Интересные статьи